AI Model Efficiency Toolkit (AIMET) Forum

Installation of version 1.16.1

Hi,

I tried to install the stable version(Release version 1.16.1 · quic/aimet · GitHub) of 1.16.1 in python 3.6 environment.
When I tried to install AIMET packages, it stated wheel is not supported, then I replaced py3-none-any with cp36-cp36m-linux_x86_64 OR cp37-cp37m-linux_x86_64 but it stated 404 error as the file was not found.
So I explicitly copied the wheel file link address and installed all the packages, like this:
(python3 -m pip install https://github.com/quic/aimet/releases/download/1.16.1/AimetCommon-torch_gpu_1.16.1-py3-none-any.whl)
Once the installation was done, I get error as
import AimetTensorQuantizer # pylint: disable=import-error
ModuleNotFoundError: No module named ‘AimetTensorQuantizer’

I’m using ubuntu 18.04
cuda version : 11.2
python 3.6

I’m wondering the installation is wrong, but I get this when I try to run a quantization code: root - INFO - AIMET. So it means the AIMET installation is done right?
Can anyone help what’s going wrong here?

Interesting. Can you please post a screenshot of which command you tried and the exact error message you got?

Yes AIMET installation seems to be ok. Python import is saying it does not know the location of the AimetTensorQuantizer module. This is a C++ custom-op for PyTorch generated by the AIMET build process. You are missing setting the PYTHONPATH environment variable to allow python to find this module. Look at the installation instructions for this.
You should find the egg corresponding to this generated module in the AimetCommon package. E.g. under /usr/local/lib/python3.6/dist-packages/AimetCommon/… Or equivalent.

Thanks for your quick response!

This is the error I got while I tried to install.

This is a small code snippet which I tried to run, to check whether the installation is done.